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Introduction
This chapter provides an overview of the responsibilities of the PowerTrax Pro Administrator. 
Each area of administration is discussed briefly and references are given to more detailed informa-
tion found in later chapters of this manual.

Who is the Administrator?
PowerTrax Pro is designed specifically for the manufacturer’s rep industry. While the features and 
functionality of PowerTrax Pro are applicable to all rep agencies, there are certain parts of the 
application that must be customized for the unique needs of your organization. This includes add-
ing user information for the people who belong to your company, specifying your company infor-
mation (addresses, phone numbers, logos), and configuring your own custom numbering system 
for quotes and orders. The Administrator is the person in your organization who is responsible for 
setting up and maintaining this unique information.

Security Precautions
The designated Administrator for your company has access to all areas of the PowerTrax Pro data-
base. This includes the ability to add, delete or edit vital database information such as passwords 
and commission rates for sales reps. As a security measure, we recommend that you designate only 
one Administrator and one backup Administrator for your company. Giving Administrator access 
to a larger number users can leave your database open to accidental or malicious tampering.

Administrator Login
In order to access the administrative areas of PowerTrax Pro, the Administrator must log in to 
PowerTrax Pro using the ‘Administrator’ user name and a special Administrator password.

1.   Launch the PowerTrax Pro application. After a few seconds, the Password dialog appears.

Figure 1-1: Logging in as the Administrator

Introduction

The Administrator Login
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2.   Select ‘Administrator’ from the list of users, then press the Tab key on your keyboard to high-
light the ‘Password’ field.

3.   Enter the administrator password, then click ‘OK.’

You are now logged in as the Administrator and have access to all areas of the PowerTrax Pro data-
base. In particular, you have access to the Administration dialog which in turn allows you to access 
the controls for performing various administrative tasks.

Figure 1-2: Administration Dialog

You can display the Administration dialog at any time by choosing File > Administration from 
the main PowerTrax Pro menu bar.

The Administration dialog is discussed in detail in later chapters of this manual.

Overview of Administrative Tasks
There are a variety of tasks that can be performed by the PowerTrax Pro Administrator. Some tasks 
are mandatory and must be completed in order for PowerTrax Pro to function properly. Other tasks 
are optional but can be useful for customizing PowerTrax Pro for your organization.

Mandatory Administrative Tasks
The following tasks must be performed by the Administrator in order for PowerTrax Pro to func-
tion properly:

■   Adding users and setting access privileges

■   Creating sales teams

■   Specifying rep firm information (addresses, phones, logos)

■   Configuring a unique numbering system for quotes and orders. 

Note If you are not logged into PowerTrax Pro as the Administrator, the Administration dialog will be 
unavailable.

Overview of Administrative Tasks
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Adding Users and Setting Access Privileges
In PowerTrax Pro, any person who has access to the database is referred to as a “User.” The users 
in your organization must be added to the database by the Administrator. Users are given a user 
name and password, and are assigned access privileges that specify the type of tasks they can per-
form in the database. For example, one user might be able to add and delete information, while 
another user might only be allowed to view the information. See Chapter 2, for a complete descrip-
tion of how to add users to your PowerTrax Pro database.

Creating Sales Teams
PowerTrax Pro uses the concept of sales teams in order to track commissions. A sales team con-
sists of one or more users. Each member of the team is assigned a specific ‘cut’ of the team’s com-
mission. For example, if a team has three members, each member might get 10 percent of the total 
commission. Using this example, a 100 dollar commission would be divided as follows:

Member 1 $10
Member 2 -- $10
Member 3 -- $10
Company -- $70
---------------------------
Total $100

The Administrator is responsible for creating the teams, adding and deleting team members, and 
specifying each member’s commission split. See Chapter 3 for an explanation of how to create 
sales teams for your organization.

Specifying Rep Firm Information
Rep firm information refers to your company’s name, addresses, phone numbers, logo, and so on. 
It’s the Administrator’s job to add this information to the database so that will appear on your 
printed quotes and orders. See Chapter 4 for detailed instructions on how to specify your rep firm 
information.

Custom Numbering
In business, it’s important that forms such as quotes, orders, invoices and purchase orders be num-
bered uniquely for identification purposes. The Administrator can configure custom numbering 
system for your transaction forms. See Chapter 4 for information on configuring your custom 
numbering system.

Optional Administrative Tasks
In addition to the mandatory administrative tasks, there are a number of miscellaneous tasks that 
the Administrator can perform. The following tasks help to customize PowerTrax Pro for your 
company’s needs, but are not necessary for PowerTrax Pro to function:

■   Creating custom display and print formats for your quotes, orders and reports

■   Configuring custom database fields to hold information that is unique to your organization

■   Editing and maintaining choice lists for certain fields in the database

■   Importing and Exporting Data



 

Overview    1 -5

          
Display and Print Formats
The Administrator has the ability to customize the information that appears on your quotes, orders, 
invoices and purchase orders. For example, you might have a quote form that shows your com-
pany’s commission for the sale. Obviously you wouldn’t want that information to appear on the 
printed quote that you send to a customer, so the Administrator can create a custom print format 
where the commission is not visible. That way, you can have an ‘on-screen’ form that shows your 
commission and a printed form that hides the commission.

The Administrator is also able to specify custom formats for any reports that you generate from 
PowerTrax Pro. See Chapter 5 for complete details of how to create custom formats.

Custom Fields
The Contacts input form in PowerTrax Pro contains data entry fields that hold information com-
monly used by most businesses. However, each business is different and it’s possible that your 
organization might want to store information that’s unique to your needs. Perhaps you want to 
store data on whether a customer prefers to be contacted by phone, fax, or email. To accommodate 
this type of situation, the Contacts input form comes with 18 fields that the database Administrator 
can configure to hold unique data. See Chapter 6 for information on setting up custom fields.

List Management
Throughout the PowerTrax Pro database, you’ll see many fields with a small triangle beside them. 
This triangle indicates that the field has a choice list associated with it.

Figure 1-3: Choice Lists

A choice list allows the user to fill in a field by selecting a choice rather than typing an entry each 
time. For example, the ‘Salutation’ field on the Contacts input form is always filled in with ‘Dr.’ 
‘Mr.’ ‘Mrs.’ or ‘Miss’. Rather than have the user type one of these values each time, PowerTrax 
provides that field with a choice list containing the three values. The user can quickly select a 
choice from the list instead of typing.

The choice lists in PowerTrax Pro contain default choices that are commonly used by most busi-
nesses. However, because each business is different, the Administrator can edit the items in any 
choice list to better reflect an organization’s needs. For example, the choice list for the ‘Salutation’ 
field could be changed to the items ‘Dr.’ ‘Mr.,’ ‘Mrs.’ and ‘Ms.’ See Chapter 7 for details about list 
management.

Importing and Exporting Data
To avoid tedious and error-prone rekeying of data, PowerTrax Pro provides import and export fea-
tures that allow you to move data into—and out of—your database quickly and efficiently in the 
form of delimited text files. See Chapter 8 for details about importing and exporting data.

Click the triangle... ...to display a choice list.
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Maintenance Tasks
From time to time the Administrator will need to perform maintenance tasks that keep your Power-
Trax Pro database up to date. For example, when you receive a new update to your PowerTrax Pro 
application, the Administrator needs to update the PowerTrax Pro search engine so that it will 
search any new fields or tables that might have been added to the new update. See Chapter 9 for a 
discussion of administrative maintenance tasks.
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This chapter shows you how to add new users to your PowerTrax Pro database. You’ll also learn 
how to create user names and passwords, and how to set access privileges for each user.

Adding New Users
The first task involved in setting up your database is to create a user name and password for each 
person who will use the PowerTrax Pro application.

1.   After logging in as the Administrator, choose File > Administration from the menu bar. The 
Administration dialog appears showing a list of Administration areas.

Figure 2-1: Administration Areas

2.   Select ‘Password Editor’ from the list, then click ‘OK.’ The Password Editor window appears.

Figure 2-2: The Password Editor

The Password Editor window contains four scrolling lists that give information about the Users 
and Groups in your PowerTrax Pro database. A User is a person who is authorized by the
Administrator to use the PowerTrax Pro application. A Group is a collection of one or more Users. 

Adding New Users

User List Group List

The selected User
belongs to the
Groups shown here.
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Each Group has specific access privileges that determine the kind of tasks the Users assigned to 
that Group can perform. See “Groups” later in this chapter for more information.

The lists on the left side of the Password Editor window show the names of the database Users and 
any Groups that they belong to. The lists on the right side of the window show the names of 
Groups and the names of any Users who are members of those Groups. 

To add a new user:

1.   Choose Password > New User. The User input form appears.

Figure 2-3: User Input Form

2.   Enter the name of the new user in the ‘User Name’ field, then press Tab.

Figure 2-4: Entering a User Name

3.   Enter a password for the new user in the ‘Password’ field.

Figure 2-5: Entering a User Password

4.   Click ‘OK.’ The new user now appears in the User list on the Password Editor.

Note Passwords are case sensitive. This means that upper and lower case letters are considered to be 
different. Be sure that the Caps Lock key on your keyboard is not on when you enter the pass-
word for the user.



 

2 -4      Adding Users

         
Figure 2-6: New User Added

Groups
PowerTrax Pro comes with a set of predefined Groups that you can assign Users to. Each Group 
has specific access privileges that determine the kind of tasks the Group members can perform. For
example, the ‘Read Only’ Group is configured to only allow ‘Read’ access. This means that any 
Users assigned to this Group can view, but not add or change data.

Assigning a User to a Group
1.  Click the name of the User you want to assign, then hold down the mouse button and drag the 

User onto the Group you want to assign him or her to. When the Group becomes highlighted, 
release the mouse button.

Figure 2-7: Assigning Users to Groups

The User becomes a member of the selected Group, and the User’s name appears in the scroll-
ing list below the list of Groups.

Note Once you’ve added a new user with the Password Editor, you must open the PowerTrax Pro 
Users table and create a User record for that person. See “Creating a User Record” on page 8. 

Groups

Click the User... ...and drag to the Group
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Figure 2-8: User Assigned to Group

To see which Group a User belongs to:

1.  Click the User’s name in the ‘Users’ list. The name of the User’s assigned Group appears in the 
scrolling list below.

Figure 2-9: Viewing a User’s Group

This list shows the members
of the selected Group.

This list shows the Groups that
the selected User is a member of.

Click a User name...

...the User’s assigned
Group appears here.
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To see which Users are members of a particular Group:

1.  Click the Group name in the ‘Groups’ list. The names of all assigned Group members appear in 
the scrolling list below.

Figure 2-10: Showing Group Members

Removing a User From a Group

To remove a User from a Group:

1.   Click Group name in the ‘Groups’ list. The names of all Group members appear below.

Figure 2-11: Removing a User from a Group

2.   Click the name of the User you want to remove from the Group and drag it back to the ‘Users 
list on the Password Editor window. The User’s name no longer appears in the list of Group 
members.

Click a Group name...

...the names of the Group
members appear here.

Click and drag the User name back to
the Users list to remove it from the Group.
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Saving Your Groups (Very Important!)
Anytime that you receive an update to your current PowerTrax Pro version, it’s crucial that you 
save your current group configurations before updating. If you do not save your groups before 
installing a new update, the data describing which users are members of which groups will be lost, 
and group membership will have to be reconfigured.

To save your current Group configuration:

1.   With the Password Editor open, choose Passwords > Save Groups. The standard Save dialog 
for your operating system appears.

2.   Enter a name for the Group file and select a location to store it.

3.   Click ‘Save.’

Loading a Saved Group File
After installing a new update of PowerTrax Pro, you’ll need to load the Group file that you saved 
previously.

1.   With the Password Editor open, choose Passwords > Load Groups. The standard Open dialog 
for your operating system appears.

2.   Select the Group file that you want to load, then click ‘Open.’ PowerTrax Pro will load your file 
and restore the saved Group configuration.

Note You must be logged into PowerTrax Pro as the Administrator in order to save Groups.

Note You must be logged into PowerTrax Pro as the Administrator in order to load Groups.
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Creating a User Record
After you add a new user with the Password Editor, you must open the PowerTrax Pro Users table 
and create a User record for that person. Unless a User record is created, the individual will not be 
able to log in and use PowerTrax Pro. A User record contains personal information such as the 
user’s name, employment start date, and commission rate. You also use the User input form to add 
the user to one or more sales teams, and to create an e-mail account for the user.

To add a new user record:

1.   Click the ‘Users’ button on the Navigation Palette to open the Users table.

2.   Click the ‘Add’ (+) button. A blank Users input form appears.

Figure 1-12:  New User Input Form

3.   Enter the user’s name and address information at the top of the input form.

The bottom half of the input form contains a series of Tabs where you can enter the user’s personal 
information, sales team assignment and e-mail account. These Tabs are described in detail in the 
following sections.

The Personal Tab
The Personal Tab (shown above) allows you to enter personal user information such as a start date, 
commission rate, data entry defaults and emergency contact data.

1.   Make sure the ‘Active’ checkbox is selected, then enter the new user’s ‘Start Date,’ ‘Social 
Security #’ and ‘Commission Rate’ in the fields provided.

Creating a User Record (Very Important!)
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The Defaults section of the Personal Tab allows you to customize various data entry defaults for 
the new user.

Figure 2-13:  Data Entry Defaults

Show All Users
Each contact record in PowerTrax Pro contains a list of activities (phone calls, meetings, etc.) that 
involved that contact. If the ‘Show All Users’ checkbox is selected, the contact activity list will 
show activities for all users in your company who have dealt with the contact. By default, the 
‘Show All Users’ checkbox is not selected. This means that the contact activity list will show only 
the activities that were carried out by this user. See Chapter 4 of the PowerTrax Pro User’s Guide 
for information about contacts and activities.

Capitalize
The ‘Capitalize’ radio buttons allow you to specify how data will be displayed when entered by 
this user. If ‘No’ is selected, all the data entered by this user will appear in lower case letters. If 
‘First Word’ is selected, the first word of each entry will be capitalized (john smith --> John smith). 
If ‘All Words’ is selected, all words in each entry will be capitalized (john smith --> John Smith).

Default Color
PowerTrax Pro’s scheduling window displays the scheduled activities for all users in your com-
pany. Each user’s activities can be color coded to make it easier to see which activities belong to 
which users. To assign a color code for the new user’s activities, simply click the ‘Default Color’ 
control and select a color from the palette that appears.

Figure 2-14: Color Palette

See Chapter 6 of the PowerTrax Pro User’s Guide for information about the scheduling window.

2.   After setting the user’s defaults, enter any emergency contact information at the bottom of the 
Personal Tab. (Optional)

Note The value you enter in the ‘Commission Rate’ field is used to specify the user’s commission 
splits when you assign them to a sales team. See “The Sales Team Tab” below for details.

Click to display the palette
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The Sales Team Tab
In order for PowerTrax Pro to track commissions, each sales person must belong to a sales team. If 
you’ve already created one or more sales teams, you can assign the user to a team using the con-
trols available here. If you haven’t already created your sales teams, you can open the Sales Team 
table, create the teams and assign the user to a team from there. See Chapter 4 for information 
about creating sales teams.

If you’ve already created a team and wish to assign this user to it:

1.   Click the Sales Team tab on the Users input form.

Figure 2-15: Sales Team Tab

2.   Click the ‘Add’ (+) button next to the Sales Team list. A list of available sales teams appears.

Figure 2-16: List of Sales Teams

3.   Highlight the team you want to add the user to, then click ‘Select.’ The name of the team will 
appear in the Sales Team list, indicating that the user is now a member of that team.
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Creating an E-Mail Account
In order for a user to be able to access PowerTrax Pro’s built-in e-mail features, you must create an 
e-mail account for that user. This process includes adding an account name and password, specify-
ing an e-mail address, and identifying your organization’s SMTP server.

To create a user’s e-mail account:

1.   Click the Email Accounts Tab on the Users input form.

Figure 2-17: Email  Accounts Tab

2.   Click the ‘Add’ (+) button next to the list of E-Mail Accounts. A blank E-Mail Account input 
form appears.

Figure 2-18: E-Mail  Account Input Form
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3.   Enter the account information as shown in the table below:

Account Preferences

Setting Mail Folder Preferences
The Folder tab let’s you choose when mail should be automatically deleted.

Figure 2-19: Folder Preferences

By default, mail will not be deleted until the user clicks the Delete button. However, by using the 
Auto Delete options, the user can have mail deleted automatically. For each folder, you can delete 
all messages in a folder or delete only those messages that are older than the number of days you 
specify.

Preference Description

Account Name The name you want to attach to the user’s e-mail account. This is usu-
ally the user’s name (i.e. Bob Smith)

Account Password Blocks other users from accessing the account without authorization 
(i.e. they have to have the password). If the field is left blank, others 
can automatically access the account. 

E-mail Address The user’s Internet e-mail address (Tim@softsinc.com for example). 

E-mail Password The e-mail password to the user’s e-mail account on your POP3 
Internet e-mail server.

SMTP Server The Internet address of your SMTP (outgoing) e-mail server
(mailaustin.computize.net for example).

Signature You can type a personalized signature that can be included on the 
user’s outgoing e-mail messages.
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1.   Click the ‘Deleted Mail’ or ‘Sent Mail’ checkboxes (or both) to indicate which folders you 
want to use automatic deletion on.

2.   If you want to automatically delete all messages from the selected folder, click the ‘all mes-
sages’ radio button.

3.   If you want to automatically delete only messages a certain number of days old, click the ‘mes-
sages that are’ radio button, the enter the number of days that you want.
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This chapter shows you how to set up sales teams in order to track commissions and set sales 
objectives. You’ll learn how to create a team, add and delete team members, specify commission 
percentages and set sales objectives for that team.

Creating Sales Teams
In order for PowerTrax Pro to track commissions, each sales person must belong to a sales team. A 
sales team can have one or more members, and each member is assigned a set commission rate.

Creating a Sales Team

1.  Click the ‘Sales Teams’ button on the Navigation Palette to open the Sales Teams table.

2.   Click the ‘Add’ (+) button at the bottom of the Sales Team list screen. A blank Sales Team 
input form appears.

Figure 3-1: Sales Team Input Form

3.   Enter a name for the sales team. If the team has only one member, it’s acceptable to use that 
member’s name as the team name. Otherwise, it’s best to use a descriptive name for the team.

Creating Sales Teams
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4.   Click either the ‘Buy/Sell’ or ‘Sales Rep’ radio button to specify the business structure of the 
current sales team.

5.   Once you’ve established the team name and business structure, you can begin adding team 
members. Click the ‘Add’ (+) button to display the list of sales reps (users) in your company.

Figure 3-2: List of Sales Reps

6.   Click the user you wish to add, then click the ‘Select’ button. The user appears in the list of 
team members. Notice that the commission percentage is automatically set. This commission 
percentage is determined when the User record is created. See Chapter 2 of this guide for 
details about creating a User record.

Figure 3-3: New Team Member

The ‘Cumulative Commission %’ field shows the total commission percentage for the entire 
team.When another team member is added, that member’s commission percentage will be 
added to the team total.

Note If there is only one rep firm specified in your PowerTrax Pro database, the ‘Rep Firm’ field is 
filled in automatically for you. If your database has multiple rep firms specified, tab into the 
‘Rep Firm’ field to display a list of the rep firms. Simply select the firm you want to assign the 
current team to.

Rep’s commission percentage

Total team percentage
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7.   Repeat Steps 5 and 6 to add more team members.

8.   If desired, you can enter a description of the sales team in the ‘Description’ field.

Figure 3-4: Sales Team Description

9.   Click the ‘Save’ button on the input form to save the new sales team.

Editing a Team Member
To view and edit the details of any team member:

1.   Double-click the member’s name in the team list on the Sales Team input form. The User Sales 
Team input form appears.

Figure 3-5: User Sales Team Input Form

2.   Using this input form, you can change both the user name and commission percentage. Click 
the ‘Save’ button to save any changes you make.

Note Remember to set aside a percentage of the team commission to go to your business rather than 
to a sales rep. For example, if the ‘House Account’ receives70% of the commissions received 
from a principal, the remaining 30% must be divided among the other members you add to the 
team. The total team percentage cannot exceed 100%.
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If you’ve specified the team business structure as ‘Reseller,’ you’ll see two additional fields on 
the User Sales Team input form—“Commission Basis’ and ‘Minimum Pricing.’

Figure 3-6: Input Form with Extra Fields

3.   If you click the ‘Commission Basis’ field, a list of choices appears.

Figure 3-7: Choices for Commission Basis

4.   Select the commission basis you want, then click ‘OK.’ If you want to add more items to the 
list, click ‘Modify.’

Figure 3-8: Modifying the Commission Basis List
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5.   Click ‘Append’ to add a new item to the end of the list. Click ‘Insert’ to insert a new item 
directly above the currently selected item. Click ‘Delete’ to remove a selected item. After 
you’ve made the changes you want, click ‘OK’ to return to the User Sales Team input form.

You can also specify a minimum price for any items sold.

6.   Click the ‘Save’ button to save any changes you make.

Adding Sales Objectives
The Sales Team input form contains a list where you can edit and view sales objectives for the cur-
rent sales team.

Figure 3-9: Sales Objective List

 In PowerTrax Pro, setting sales objectives is a three step process. First you set yearly sales objec-
tives for each principal (see Chapter 2 of the PowerTrax Pro User’s Guide). Second, you set sales 
objectives for each customer so you know how much each one has to buy in order to meet your 
principal objectives (see Chapter 5 of the PowerTrax Pro User’s Guide). Finally, you assign those 
principal and customer sales objectives to your sales teams.

To assign a sales objective to a sales team:

1.   Click the ‘Add’ (+) button to the left of the Objectives list. The Objectives input form appears.

Figure 3-10: Objectives Input Form

Adding Sales Objectives
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2.   Enter the fiscal year that you’re targeting in the ‘Objectives for Fiscal Year’ field.

3.   Fill in the ‘Bookings,’ ‘Commissions’ and ‘Profit’ objectives for the entire fiscal year.

Once you’ve established the overall objectives for the current team, you can break that objective 
down by principal and by customer using the Tabs at the bottom of the Objectives input form.

To break your objective down by principal:

4.   Click the ‘By Principal’ Tab, then click the ‘Add’ (+) button. A list of principal objectives for 
the current year appears.

Figure 3-11: Principal Objectives

5.   Highlight the principal objectives that you want to assign to this team, then click ‘Select.’ The 
selected objectives now appear in the list on the By Principal Tab.

Figure 3-12: Objectives by Principal
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To break down your yearly objective by customer:

1.   Click the ‘By Customer’ Tab, then click the ‘Add’ (+) button. A list of customer objectives for 
the current year appears.

Figure 3-13: Customer Objectives

2.   Highlight the customer objectives that you want to assign to this team, then click ‘Select.’ The 
selected objectives now appear in the list on the By Customer Tab.

Figure 3-14: Objective by Customer

3.   Click the ‘Save’ button to save the record. The new objective appears in the Sales Objectives 
list on the Sales Team input form.

Figure 3-15: New Sales Objective
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This chapter shows you how to personalize PowerTrax Pro for your organization by adding com-
pany information such as billing and shipping addresses, phone and fax numbers, and company 
logos. You’ll also learn how to create your own auto-numbering system for quotes and orders. For 
resellers and buy/sell reps, this chapter includes information on how to specify the pricing your 
organization receives from your suppliers.

Adding Company Information
A Rep Firm record contains a variety of information about your company including your company 
name, addresses, phone numbers, logos, price schedules, sales teams, and the numbering system 
for your quotes, orders, and purchase orders. This section describes how to add your basic com-
pany information (name, address, phone numbers and logo) to PowerTrax Pro.

Initially, your PowerTrax Pro database does not contain any Rep Firm records. You must create a 
new Rep Firm record before you can add your company information.

To create a new Rep Firm record:

1.   Click the ‘Rep Firms’ button on the Navigation Palette to open the Rep Firms table.

2.   Click the Add (+) button at the bottom of the list screen. A blank Rep Firm input form appears.

The first Tab you see is the Address Tab. The Address Tab is designed to hold general company 
information such as your company name, address, phone information and tax status.

Figure 4-1: Rep Firm Input Form

3.   Enter your company name in the ‘Company’ field.

4.   Enter your company’s billing and shipping addresses in the fields provided.

5.   Enter your company’s phone, fax, and web site (if applicable) information in the appropriate 
fields under the ‘Other Information’ section.

Adding Company Information
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6.   Enter your company’s tax identification number in the ‘Tax ID #’ field.

7.   If your organization is tax exempt, click the ‘Tax Exempt’ checkbox.

8.   Enter your local sales tax percentage in the ‘Local Sales Tax %’ field.

9.   If you place time limits on your quotes (15 days, 30 days, and so on) enter the number of days 
that quotes are valid in the ‘Quote Validity’ field. When a salesperson issues a quote, Power-
Trax Pro will use the number you enter here to calculate the expiry date for the quote.

The Logo Tab
The Logo Tab provides a place to store your company logo so that it will appear in the header of 
your printed quotes, orders, invoices, and purchase orders.

Figure 4-2: Logo Tab

To add your company logo:

1.  Copy your company logo to your computer’s Clipboard.

2.   Open the Rep Firm input form, then click the Logo Tab.

3.   Click the ‘Company Logo’ field to select it.

4.    Paste your logo into the field.

Figure 4-3: Pasting a Logo

5.   After adding your company information and logo, click ‘Save’ to close the Rep Firm input 
form and save your data, or continue on and fill out the remaining Tabs. See the following sec-
tions for details about filling out the other Rep Firm input form Tabs.

Click in the logo field
and paste your logo.
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The Sales Team Tab
PowerTrax Pro uses the concept of sales teams to track commissions for sales people in your orga-
nization. Each sales team has one or more members, and each team member is assigned a specific 
‘cut’ of the team’s commission.

The Sales Team Tab is used to display a list of all the sales teams that have been configured for 
your organization.

Figure 4-4: Sales Team Tab

Automatic Number Generation
Transactions such as quotes, purchase orders and invoices need to be numbered uniquely for iden-
tification purposes. By default, PowerTrax Pro will number your transactions sequentially as each 
record is created (1,2,3,4…and so on). The Administrator can use the Preferences Tab to configure 
an automatic numbering system that’s customized for your company’s needs. For example, instead 
of using plain numbers for quotes, you can have quote numbers that use a number plus text such as 
your company name (MyCo1, MyCo2, MyCo3…and so on).

The Sales Team Tab

Note The information on the Sales Team Tab is for display only. To add, delete or edit sales team 
information, you must open the Sales Team table and use the Sales Team input form. See Chap-
ter 3 of this manual for details.

Automatic Number Generation
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Your autonumbering system can be made up of any combination of the following components:

■   the current date

■   a sequential number

■   static text

The instructions below show how to configure an autonumbering definition that uses static text and 
a sequential number (MyCo1, MyCo2, MyCo3).

1.   Open your Rep Firm record and click the Preferences Tab.

Figure 4-5: Rep Firm Preferences Tab

The Preferences Tab is made up of two separate sections. The top section is used to specify 
custom formats for your printed reports. The bottom section contains the controls for configur-
ing an autonumbering system for your company’s quotes, purchase orders and invoices. The 
information below deals with configuring an autonumbering system. For information on how 
to specify custom formats for reports, please see Chapter 5.

2.   Go to the ‘Quote Number Definition’ section.

Figure 4-6: Quote Number Definit ion

The list on the left contains the items you can use to make up your custom numbers. The Con-
trol buttons allow you to append, insert, or remove items in your number definition. The list on 
the right displays the items that have been inserted or appended.

List of items Control buttons

Number definition appears here

Field to enter static text
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3.   Select ‘Static Text’ then click the ‘Insert’ button. The Static Text item appears in the list on the 
right.

Figure 4-7:  Stat ic Text  I tem Added

When you use the Static Text item, you must specify what text you want to appear in the num-
ber definition by entering a value in the ‘String’ field.

4.   Using our current example (MyCo1, MyCo2, etc.) you would type ‘MyCo’ in the ‘String’ field.

Figure 4-8:  Specifying the Text

5.   Select the ‘Sequence Number’ item and click ‘Append.’ PowerTrax Pro will add the Sequence 
Number item after the Static Text item.

Figure 4-9: Sequence Number Added

When you include the ‘Sequence Number’ item in your definition, you’re instructing Power-
Trax Pro to use the next available sequence number when a new transaction is created. For 
example, if the last quote number was ‘MyCo100,’ the next sequential number would be 
‘MyCo101.’ See “The Sequence Number Editor” later in this chapter for information on how 
to specify where your number sequences begin.

The last step is to specify when the quote, purchase order, or invoice number will be generated. 
PowerTrax Pro can generate a sequential number when the user selects a transaction type, or 
when the user adds the first line item to a transaction.

Type your text value here.
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To specify when a number is generated:

6.   Click the ‘When to create numbers’ pull-down list and select an option.

Figure 4-10: When to Create Numbers

The Order of Items
It’s important to note that top-to-bottom ordering of the number definition items determines how 
your number definition will look. Using the example shown in the following illustration, the top-
to-bottom order of items would produce text followed by a number (MyCo1).

Figure 4-11:  Text and Number

If you change the top-to-bottom order of the items in the right hand list, you change how the fin-
ished number definition will look.

Figure 4-12: Changing the Order of I tems

For example, putting the sequence number first, followed by the static text as in the illustration 
above, would produce 1MyCo, 2MyCo, and so on.

You use the ‘Append’ and ‘Insert’ buttons to determine the order of the items in your definition. 
Whenever you add an item from the list on the left to the list on the right, that item becomes the 
currently selected item in the right list.

The order of these items determines
how the finished number will look.

Changing the order of items
changes the finished number.

Newly added item is selected.
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When you select the next item to be added:

■   Clicking ‘Append’ will append the next item after the item that’s currently selected in the right 
hand list.

■   Clicking ‘Insert’ will insert the next item before the item that’s currently selected in the right 
hand list.

The Sequence Number Editor
PowerTrax Pro’s default numbering sequences for each data table begin at the number one (1). For 
example, when you add your first contact record, that contact would be record 1. The next contact 
you add would be record 2, and so on.

As the Administrator, you can change the default sequence so that your records start at a different 
number. For example, if you’re switching to PowerTrax Pro from another database, you probably 
already have a number of quotes in the old database. Suppose that the last quote in the old database 
is quote #100. You’d want you first PowerTrax Pro quote to be #101, not #1.

Changing the start of your number sequences is done with the Sequence Number Editor.

1.   Choose File > Administration from the main PowerTrax Pro menu bar. The Administration 
dialog appears.

Figure 4-13: Administration Dialog

2.   Select ‘Sequence Number Editor, then click ‘OK.’ The Sequence Number Editor appears.

Note We recommend that you only change your numbering sequences under the supervision of Soft 
Solutions technical support.
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Figure 4-14: Sequence Number Editor

The numbered list on the left shows each table in the database. When you select a table, its 
name appears below the list and the next available record number for that table is displayed in 
the ‘Next Number’ field.

By default, sequence numbers for each table start at 1 and increase by 1 each time a record is 
added. To change the starting number for any table:

1.   Select the table you want by clicking its number in the list. 

2.   Enter the number you wish to use in the ‘Next Number’ field. For example, if you want the 
next available record number to be 75, enter ‘75’ in the ‘Next Number’ field.

3.   Click ‘Done’ to update the numbering sequence.

Adding your Cost of Goods
If you’re a reseller or a buy/sell rep, use the Principal Prices Tab to specify your cost when buying 
product from your suppliers.

Note When you change a numbering sequence it only affects the numbering for the selected table. 
The numbering for all other tables remains the same.

Adding your Cost of Goods

Note Principals and their corresponding price schedules must be added to your database before you 
can assign a price schedule to your rep firm. See Chapter 2 of your PowerTrax Pro User’s Guide 
for details about how to add principal information and price schedules.

List of Tables

Next available number 
for the selected table

Name of selected table
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Once principal information and price schedules are available:

1.  Click the Principal Prices Tab on the Rep Firm input form. Initially, the list of prices is blank.

Figure 4-15: Principal Prices Tab

2.   Click the ‘Add’ (+) button. A list of principal price schedules appears.

Figure 4-16: Principal Price Schedules

3.   Select the price schedule you want, then click the ‘Select’ button. The price schedule now 
appears in the list on the Principal Prices Tab. A list of that principal’s products and appropriate 
prices also appears.
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Figure 4-17: New Schedule Added

4.   Click the ‘Save’ button to save your changes.
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Introduction
Each company’s information needs are unique, so PowerTrax Pro gives the database Administrator 
the ability to customize the display and print layouts for quotes, orders, invoices and purchase 
orders. For example, you can specify that an ‘on screen’ quote form shows a quantity, size, color, 
price and commission amount for each line item.

Figure 5-1: Quote Transaction Form Showing Commission

Obviously you would not want a commission amount appearing on the printed quote that gets sent 
to a customer, so you can specify that the print format of the same quote form will not show the
commission amount.

Figure 5-2: Quote Transaction Form Showing No Commission

Each type of transaction—quotes, orders and so on—can have multiple display formats and multi-
ple print formats. You specify these different formats in the Format Definitions table.

Defining a Format
To define a format:

1.    Click the ‘Format Definitions’ button on the Navigation Palette. PowerTrax Pro displays a list 
of all available Format Definitions.

2.   Click the ‘Add’ (+) button at the bottom of the Formats list screen. The Format Definition input 
form appears.

Introduction

Note The Format Definitions feature can only be accessed by the database Administrator.

Defining a Format
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Figure 5-3: Format Definit ion Input Form

3.   Click the ‘Primary Table’ field and select either the ‘Line_Items - Orders’ table or ‘Line_Items 
- Invoices’ table. The contents of the ‘Available Fields’ list will change depending on which 
table you specify.

4.   The ‘Format Name’ field is highlighted. Enter a name for the new format here. To make it eas-
ier for your users to identify the format it’s recommended that you use a descriptive name. For 
example, “Quote w/commission” or “Quote w/o commission.”

5.   Next, specify the type of transaction that this format will be used with by selecting an option 
from the ‘Type’ pull-down list.

Figure 5-4: Format Types

If you select the ‘Quote’ type, your Format Definition will only be available when a user cre-
ates a Quote transaction. If you select the ‘Order’ type, the Format Definition will only be 
available when a user creates an Order transaction, and so on.

Note To create a new format definition for use with a quote, order, reseller quote, reseller order, or 
purchase order, select the ‘Line_Items - Orders’ table. If you select the ‘Line_Items - Invoices’ 
instead, your new format can only be used for invoice records.
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6.   Specify whether the new format is to be used for display or printing by clicking either the
‘Display’ or ‘Print’ radio button. If you select the ‘Print’ option, the ‘Print Mode’ pull-down 
list appears, allowing you to select either the ‘Portrait’ or ‘Landscape’ option.

Figure 5-5: Print Mode Options

7.   Specify a font size and font for the information in your format by selecting items from the 
‘Font Size’ and ‘Font Name’ pull-downs. These settings determine how the line item informa-
tion will appear when a user creates a transaction record using this Format Definition.

Figure 5-6: Font Options

Selecting Fields for Display
The ‘Available Fields’ list shows the names of all fields that are available for display. The ‘Field’ 
column shows the name of the field. The ‘Table’ column shows which table the field belongs to.

Figure 5-7: List of Available Fields

Each field selected from this list will appear as a column in the ‘Line Items’ section of the corre-
sponding transaction input form. For example, if you select the Part Number, Quantity, Price, and 
Extended Price fields, the ‘Line Items’ section of the Orders input form would look like this:

Figure 5-8: Part Number, Quantity,  Price, Extended
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If you were to select the Quantity, Size, Color, and Price fields instead, the ‘Line Items’ section of 
the Orders input form would look like this:

Figure 5-9: Quantity, Size, Color, Price

To include a field in your format:

1.    Click and drag it from the ‘Available Fields’ list to the ‘Selected Fields’ list.

Figure 5-10: Selecting a Field

2.   Repeat this for each field that you want to have as a column on your input form.

Click the field... ...drag it over... ...and release the mouse button...

...the field now appears in the ‘Selected Fields’ list.
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Formatting a Column
Each selected field can also have a specific data format assigned to it. For example, if you’ve 
selected the ‘Total’ field to appear on an Order input form, you might want the data in the resulting 
column to show a currency symbol and two decimal places.

1.   To specify a format for a field, first click the field in the ‘Selected Fields’ list, then click the 
pull-down icon and select one of the available formats.

2.   To specify the width of the column that will appear on the input form, double-click the cell in 
the ‘Width’ column to select it, then type the new value and press Tab.

Figure 5-11: Formatting a Column

Specifying a Sort Order
You can also specify how the line items on the transaction input forms will be sorted. Suppose 
there are four line items on a Quote input form. You could sort them by price or product name or 
commission amount, or by all three. The figure below shows the line items sorted by price.

Figure 5-12: I tems Sorted by Price

By simply specifying a new sort order on the Format Definition input form, the same Quote input 
form shown above would show the line items sorted by principal.

Figure 5-13: I tems Sorted by Principal

Shows the format for the selected field. Click here to
choose a format.

Double-click this cell to
specify a new column width.
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To specify a sort order:

1.   Click the field you want to sort on in the ‘Selected Fields’ list and drag it to the first ‘Sort by’ 
field.

Figure 5-14: Specifying a Sort Order

2.   Click the ‘Ascending’ or ‘Descending’ radio button to specify the sort direction.

3.   You can specify up to three separate sorts. If you want to clear the sort order you’ve created, 
click the ‘Clear Sort’ button and start again.

4.   After you’ve configured your Format Definition, click the ‘Save’ icon to save the new record.

When a user creates a new transaction record, the new Format Definition will appear in the list of 
Format Definitions on the appropriate transaction input form.

Figure 5-15: List  of Format Definit ions

For information on using Format Definitions with input forms, see Chapters 10 and 11 of the 
PowerTrax Pro Users Manual.

Custom Formats for Reports
PowerTrax Pro comes with a set of built-in reports that you can use to view your data. These 
reports have default settings for attributes such as the body font and font size for the report. The 
Administrator can change these default attributes to customize the look of a printed report so that it 
matches your other business documents.

Custom Formats for Reports

Click and drag a field to the ‘Sort by’ field
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To customize the attributes of a report:

1.   Click the Rep Firm button on the Navigation Palette to open the Rep Firm table.

2.   Double-click your Rep Firm record to open it, then click the Preferences Tab on the Rep Firm 
input form.

Figure 5-16: Rep Firm Preferences

The top half of the Preferences Tab contains the controls for customizing reports. The bottom 
half contains the controls for configuring automatic number generation for quotes, PO’s and 
invoices. For information about automatic number generation, please see Chapter 3 of this 
manual.

3.   Click the ‘Body Font’ pull-down list and select the font that you want to use in your reports. 
The available fonts depend on which fonts are installed on your computer.

4.   Click the ‘Override Default’ checkbox to tell PowerTrax Pro to use your new settings rather 
than the default report settings.

To add a custom footer to the report:

5.   Click in the ‘Footer’ field and type the text that you want to appear in the footer.

6.   Click the ‘Footer Font’ pull-down list and select the font you want to use for the footer.

7.   Select the styles you want to use for the footer by making selections from the two ‘Styles’ pull-
down lists.

8.   Click ‘Save’ on the Rep Firm input form to save your changes.
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Introduction
The Contacts table in PowerTrax Pro is designed to store the type of Contact information that is 
commonly used by most organizations: contact names, addresses, phone and fax numbers, and so 
on. However, many organizations have additional information requirements that are unique to their 
situation. A company that deals with foreign clients might want to keep track of currency exchange 
rates. Another company might want to store data about their clients’ birthdays.

The Contacts table contains 18 fields that you can customize to meet the unique information 
requirements for your company. For example, if some of your company’s customers like to be 
contacted by phone while others prefer e-mail, you can configure a custom field to be a
‘Contact by’ field. The person filling out the customer information can then enter the customer’s 
preferred method of contact in that field.

The custom fields can be found by opening a Contact record and clicking the ‘Custom Fields’ Tab 
on the input form.

Figure 6-1: Custom Fields Tab

Data Types
Different types of fields in PowerTrax Pro are configured to hold different types of data. For exam-
ple, a date field is configured to hold date values, a text field is configured to hold textual values 
and so on. 

The 18 custom fields are separated into the following data types:

■   Text (fields 1 - 10). Text fields can hold information such as a company name, an address, a 
comment, or a memo. Users can enter any letter, number, or symbol from the keyboard into a 
text field.

■   Number (fields 11 - 13). Use the number field type to store number values.

Introduction

Data Types



Configuring Custom Fields    6 -3
■   Date (fields 14 - 16). Use the date field type to store date values. The default display format for 
custom date fields is 00/00/0000. This means that the date December 7, 1963 would be dis-
played as 12/07/1963.

■   Yes/No (fields 17 - 18). The Yes/No field type stores values that are True or False. These fields 
appear as radio buttons that can be clicked on or off.

If you’re planning to use the custom fields feature, make sure the field you customize is of the 
appropriate data type for the information you want it to hold. For example, if you want a custom 
field to hold a birth date, you would customize one of the Date fields rather than one of the Text or 
Number fields.

Configuring a Custom Field
As with all administrative functions, you must be logged into PowerTrax Pro as the Administrator 
in order to configure the custom fields.

1.   After logging in as the Administrator, choose File > File Preferences from the menu bar. The 
File Preferences dialog appears, showing a list of the custom fields.

Figure 6-2: File Preferences Dialog

The column on the left side shows the names of the fields. This is the field attribute that you 
can customize. The column on the right shows the data type assigned to each custom field. The 
data type for each field is static and cannot be changed.

Configuring a Custom Field

Field names Field data type
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Naming a Field
 Initially, each custom field has a generic name such as Custom 1, Custom 2, and so on.

To specify a field name:

1.   Double-click the field name in the list. An input form appears allowing you to enter a name for 
the custom field.

Figure 6-3: Naming a Field

2.   Enter a name for the field, then click ‘OK.’ The new field name appears in the list of custom 
fields.

3.   Repeat this procedure for any other custom fields that you want to configure, then click ‘OK’ to 
dismiss the File Preferences dialog.

Now, if you open a Contact record and click the ‘Custom Fields’ Tab, you’ll see the results of the 
changes you made on the File Preferences dialog.

Figure 6-4: New Custom Field

New custom field name
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Introduction
PowerTrax Pro provides numerous features that make data entry tasks easier. One of these features 
is the use of choice lists for fields that always hold one of several common values. For example, 
when a user fills out an order form, the ‘Ship per’ field will usually be filled in with ‘FedEx,’ 
‘UPS,’ ‘Mail,’ and so on. Instead of typing the shipping method each time, the PowerTrax Pro user 
can select one of those entries from a list of choices.

In PowerTrax Pro, the presence of a choice list is indicated by a small black triangle to the right of 
a field.

Figure 7-1: Displaying a Choice List

The choice lists that are built into PowerTrax Pro are designed to be generic so that they are appli-
cable to most rep agencies. For example, the choice list for the ‘Salutation’ field on a Contact input 
form contains the choices “Mr.’ ‘Mrs.’ ‘Miss’ and ‘Dr.’, while the choice list for the ‘Contact Type’ 
field contains the choices ‘Customer’ and ‘Prospect.’

Not all the built-in choice lists will be appropriate for every rep agency, so PowerTrax Pro allows 
the Administrator to customize the choice lists by adding, deleting, or changing existing choices.

Introduction

Note You can add, delete and edit the items in any choice list, you cannot add or delete the choice 
lists themselves. For example, you can delete the ‘Mexico’ item from the ‘Countries’ choice 
list, but you cannot delete the ‘Countries’ choice list itself.

Click the triangle… …to reveal the list of choices
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Customizing a Choice List
The following sections describe how to custom any choice list by adding, deleting or editing items 
within that list.

Accessing List Items
In order to access the PowerTrax Pro list items, you must be logged in as the Administrator.

1.   Choose File > Administration from the main menu bar to display the Administration dialog.

Figure 7-2: Administration Dialog

2.   Select ‘List Management’ and click ‘OK,’ The Select a List dialog appears.

Figure 7-3: Select a List Dialog

3.    Select ‘List Items’ and click ‘OK.’ PowerTrax Pro will open the List Items table and display 
all the current list item records.

List items are grouped together by their parent list. The illustration on the following page shows 
the five item for the ‘Address Type’ list, grouped together.

Customizing a Choice List
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Figure 7-4: List I tem Records

Editing an Existing Item
To edit an existing item:

1.   Double-click the item in the list of item records. The List Item input form appears.

2.   Press your Tab key once to highlight the ‘List Item’ field.

3.   Enter the new item name, the press Tab again to update.

Figure 7-5: Edit ing an Item

4.   Click the ‘Save’ button on the List Item input form to save your changes.

Items are grouped by their parent list.

Original Item Name

Edited Item Name
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Adding a List Item
To add a new item to an existing choice list:

1.   Make sure the List Item table is open, then click the ‘Add’ (+) button at the bottom of the List 
Items screen. A blank List Item input form appears.

Figure 7-6: List  I tem Input Form Detai l

2.   Enter the name of the parent list in the ‘List Name’ field, then press Tab. For example, if you’re 
adding a new item to the ‘Countries’ choice list, enter ‘Countries’ in the ‘List Name’ field.

Figure 7-7: Entering the List Name

3.   Enter the name of the new choice item in the ‘List Item’ field and press Tab. For example, if 
you want to add ‘France’ to the ‘Countries’ choice list, enter ‘France’ in the ‘Name’ field.

Figure 7-8:  Entering the I tem Name

4.   Click the ‘Save’ button on the List Item input form to save the new item.

Deleting an Item
To delete an existing list item:

1.   Open the List Items table, then select the item you want to delete by clicking it once.

2.   With the item selected, click the ‘Delete’ button at the bottom of the List Items screen. Power-
Trax Pro will ask you to confirm that you want to delete the selected item.

3.   Click ‘Yes’ to delete the item.



7 -6      List Management



8

Importing & Exporting Data

In this chapter:

■   Importing Data..................................................................................8-2

■   Exporting Data..................................................................................8-4
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Importing Data
PowerTrax Pro allows you to import data from a delimited Windows file. This is particularly useful 
when you have a lot of existing information that you want to add into your PowerTrax Pro data-
base. For example, if you attended a trade show and used a card swipe machine to gather hundreds 
of contact names and phone numbers in a delimited text file, you can use the Import feature to 
bring that information quickly into PowerTrax Pro rather than having to re-key all the information 
manually.

To import a delimited Windows file into PowerTrax Pro:

1.   Open the table that you want to import data into, then choose File > Import from the Power-
Trax Pro menu bar. The Import dialog appears.

Figure 8-1: The Import Dialog

The Import dialog is used to specify the fields to import into (in the proper order), and 
the delimiters used in the Windows file.

Selecting the Import Fields
The ‘Fields from <tablename>’ area displays a list of all of the visible fields in the cur-
rent table which can be used during the import.

Figure 8-2: Fields Available for Import

Importing Data
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2.   Highlight each field to be imported and click on the ‘Append’ button. For example, if the file 
you are importing contains the fields ‘First Name,’ ‘Last Name’ and ‘Email Address’ you 
would select the ‘First Name,’ Last Name,’ and ‘Email’ fields from the list. Each field you 
select will appear in the “Fields to Import” list.

Figure 8-3: Selected Import Fields

The “Insert’ and ‘Remove’ buttons can also be used to configure the list of fields to 
import.

Setting the Delimiters
All files are imported in delimited form; each record is separated from others by a special character 
and, within a record, fields are separated by another special character. The default delimiters used 
by most applications are the Tab character (ASCII 9) for the field delimiter and the Carriage 
Return character (ASCII 13) for the record delimiter. Not all files use these, however, and the 
delimiters must be properly set for the import to function correctly.

3.   In the boxes labeled “Field Delimiter” and “Record Delimiter” enter the ASCII values 
(between 0 and 255) that are used in the file to be imported.

Figure 8-4: Delimiter Controls

4.   If the ‘Skip Header Record’ checkbox is selected, the first record of the imported file will not 
be saved. This is appropriate when importing a file that contains a header record of field names. 

Figure 8-5: Header Record Control

By default, the ‘Skip Header Record’ checkbox is turned off.

Note You cannot import into picture or subtable fields.
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Starting the Import Process

5.   Click the ‘Import’ button. The Import dialog appears.

Figure 8-6: Import Dialog

6.   Select the file to import, then click ‘Open.’ A progress dialog will appear showing you the 
progress of the import.

If you need to stop the import process, click the ‘Stop’ button on the indicator. The 
import will stop but the records already imported will not be affected.

After the import is complete, the list window for the current table will display the records that were 
created by the import process.

Exporting Data
PowerTrax Pro’s data export feature allows you to export records as a delimited Windows file. This 
feature is useful for when you want to export data to another application such as a spreadsheet.

To export data from PowerTrax Pro:

1.   Open the table you want to export data from, then find the selection of records that you wish to 
export.

2.   Choose File > Export from the PowerTrax Pro menu bar. The Export dialog appears.

Exporting Data
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Figure 8-7: Export Dialog

The Export dialog is used to specify the fields to export (in the proper order) and the 
delimiters used in the exported file.

Selecting the Export Fields

The ‘Fields from <tablename>’ area displays a list of all the visible fields in the current table that 
can be exported.

Figure 8-8: Fields Available for Export

3.   Highlight each field to be included in the export (in the order you want it included) and click on 
the ‘Append’ button. For example, if you want to export the first name, last name and phone 
number of a group of contacts, you would select the ‘First Name,’ ‘Last Name’ and ‘Email’ 
fields. Each selected field name will appear in the ‘Fields to Export’ list.

Figure 8-9: Selected Export Fields

Note Picture and subtable fields cannot be exported into a delimited file.
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Setting the Delimiters

4.   In the boxes labeled ‘Field Delimiter’ and ‘Record Delimiter’ enter ASCII values between 0 
and 255 as the field and record delimiters. The most common export format—the Tab character 
(ASCII 9) for fields and the Carriage Return character (ASCII 13) for records—is the default.

Figure 8-10: Delimiter Controls

The ‘Include Header Record’ checkbox will create a fieldname header as the first 
record of the export file. This may be useful when importing the data into another 
application such as a spreadsheet.

Figure 8-11: Header Record Control

By default, the ‘Include Header Record’ checkbox is turned off.

Starting the Export Process

5.   Click the ‘Export’ button. The Export dialog appears.

Figure 8-12: Export Dialog

6.   Specify the name and location of the file you are creating, then click Save. A progress dialog 
will appear showing you the progress of the export. 

All records in the current selection (whether highlighted or not) will be exported in the 
order that they are displayed in the list window.

If you wish to stop the export process, click the ‘Stop’ button. The export file will con-
tain the records exported before ‘Stop’ was clicked.
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The Administration Dialog
In addition to the commands described in earlier chapters of this manual, the Administration dia-
log also contains a variety of other commands that the Administrator can execute to perform minor 
maintenance of the PowerTrax Pro application. For example, if you receive an update to your Pow-
erTrax Pro application, the Administrator should perform a maintenance task called ‘Update 
Query Engine Data.’ This task updates PowerTrax Pro’s search engine so that it will be able to 
search any new fields or tables that might have been added to the latest version.

Figure 9-1: Miscellaneous Administrative Tasks

The following sections describe the ‘maintenance’ type commands on the Administration dialog.

Edit Help Message
When a user requests PowerTrax Pro’s built-in help system, the main Help dialog appears.

Figure 9-2: Help Dialog

The top right corner of the Help dialog displays a message giving the user brief instructions on 
how to use the Help system. The Edit Help Message command on the Administration dialog allows 
the Administrator to change that message.

The Administration Dialog

Change your main help message

Remove a user

Use when requesting tech support
Update the search engine

Reset autonumbering sequence

Update the Search Engine

Main help message
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To change your main Help message:

1.   Choose File > Administration from the main menu bar to display the Administration dialog.

2.   Select ‘Edit Help Message’ and click ‘OK.’ The Edit Help Message dialog appears.

Figure 9-3: Edit Help Message Dialog

3.   Enter your custom Help message, then click ‘OK.’

Remove User
For security reasons, if a member of your company leaves your employ, or is not required to use 
the PowerTrax Pro application any longer, the Administrator should remove that user from the 
PowerTrax Pro database.

To remove a user from PowerTrax Pro:

1.   Choose File > Administration from the main menu bar to display the Administration dialog.

2.   Select ‘Remove User’ and click ‘OK.’ The Remove User dialog appears.

Figure 9-4: Remove User Dialog

3.   Click the name of the user you wish to remove, then click ‘Select.’ PowerTrax Pro will ask you 
to confirm your action before removing the user from the database.
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Message Monitor
PowerTrax Pro can generate internal messages that help Soft Solutions’ technical support staff to 
diagnose any problems that might occur.

If you experience a problem while using PowerTrax Pro and require technical assistance, the Soft 
Solutions technician might ask you to display the Message Monitor.

To display the Message Monitor:

1.   Choose File > Administration to display the Administration dialog.

2.   Select the Message Monitor command, then click ‘OK.’ The Message Monitor window 
appears.

Figure 9-5: Message Monitor Window

The Soft Solutions technical support representative will give you further instructions as required.

Update Search Pop-up Lists/Update Query Engine Data
When you install an update to your PowerTrax Pro application, the Update Search Pop-up Lists 
and Update Query Engine Data commands are used to update PowerTrax Pro’s search engine.

When you search on a field that uses a pop-up list, the list of choices appear in the search editor 
window so that you can select a search value. If any new choice lists have been added to the data-
base, the Update Search Pop-up Lists command will add those lists to the search engine.

If any new fields or tables have been added to the database, the Update Query Engine Data com-
mand will add those fields and tables to the PowerTrax Pro search engine.

Reset Sequence Numbers
If a problem occurs with the automatic numbering system for your quotes, purchase orders and 
invoices, you might need to use the Reset Sequence Numbers command to correct the problem.

Note The Update Search Pop-up Lists and Update Query Engine Data commands should only be 
used under the supervision of a qualified Soft Solutions technical support representative.

Note The Reset Sequence Numbers command should only be used under the supervision of a 
qualified Soft Solutions technical support representative.
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